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1 Введение 

 
В данном руководстве приведено описание последовательности действий по созданию отчета. 
Данное руководство содержит следующие разделы: 

 Создание отчета - описание основных действий пользователя и их порядок, необходимых 
для создания отчета; 

 Приложение I Список рисунков – список рисунков, встречающихся в документе; 

 Приложение II Ссылки– список используемых документов, 

 Приложение III Служба сопровождения и поддержки – контактная информация. 
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2 Создание отчета 

В программе имеется возможность создания отчета, содержащего данные об 
обрабатываемом спектре и результаты его обработки. Отчет может быть создан следующими 
способами: 

 c помощью шаблонов отчетов (см. раздел 2.1); 

 с помощью окна Отчет (см. раздел 2.2). 
В первом случае шаблоны отчетов должны быть созданы заранее и сохранены на диск. Для 

создания отчета могут быть использованы как шаблоны, идущие в комплекте с программой, так и 
шаблоны, созданные пользователем. Подробное руководство по созданию и редактированию 
шаблонов отчетов в разделах 2.1.1 и 2.1.2. 

2.1 Работа с шаблоном отчета 

Чтобы создавать отчет с помощью шаблона, необходимо указать нужный шаблон в 
параметрах конфигурации. Выберете пункт меню Файл => Параметры конфигурации или 

нажмите на кнопку   инструментальной панели. В появившемся окне Параметры 
конфигурации в категории Размещение файлов укажите .frf–файл шаблона отчета в поле Файл 
отчетов. По умолчанию шаблоны отчетов хранятся в папке \Reports рабочей директории, хотя это 
не обязательное требование.  

2.1.1 Создание нового шаблона отчета 

Чтобы создать новый шаблон отчета откройте дизайнер отчетов, выбрав Файл => Отчет =>  

Дизайн…. Можно выбрать File => New или нажать кнопку  панели инструментов, тогда 
откроется новая форма для создания будущего отчета. Мы рекомендуем следующий путь: 
откройте любой шаблон, поставляемый в комплекте с программой, выбрав File => Open или нажав 

на кнопку  инструментальной панели, сохраните его под другим именем, выбрав File => Save 
as, в удобном месте и отредактируйте (см. раздел 2.1.2). Этот путь предпочтительнее, так как 
поставляемые в комплекте с программой шаблоны содержат «словарь» переменных, что 
значительно облегчит пользователю работу. 

2.1.2 Редактирование шаблона отчета 

Чтобы редактировать шаблон отчета, выберите Файл => Отчет =>  Дизайн…. По умолчанию 
в окне дизайнера открывается подготовленная форма отчета, связанная с окном Отчет (см. 

раздел 2.2). Этот отчет можно просмотреть, выбрав File => Preview или нажав кнопку  
инструментальной панели. 

В открывшемся окне дизайнера отчетов выберите File => Open или нажмите на кнопку  
инструментальной панели и выберите подлежащий редактированию файл шаблона. Для 
редактирования отчета пользователю доступны средства дизайнера отчетов (см. раздел 2.1.3.1), 
список переменных отчета, заложенных в шаблон (см. раздел 2.1.3.3), а также имеется 
возможность вставки графика спектра в отчет (см. раздел 2.1.3.4). После завершения 

редактирования сохраните шаблон, выбрав File => Save или нажав кнопку  инструментальной 
панели. 

Внимание: просмотреть отчет, соответствующий открытому шаблону, через Preview нельзя, 
поскольку данные для этого отчета готовятся только при вызове этого отчета из главной 
программы (см. руководство [1]). 

2.1.3 Дизайнер отчетов 

Дизайнер отчетов является инструментом FastReport, предоставляющим пользователю 
удобную среду для разработки отчетов. 

2.1.3.1 Визуальные объекты 

Визуальные объекты предоставляют пользователю широкие возможности в формировании 
внешнего вида отчета. В данном разделе описаны только те объекты, которые использовались в 
шаблонах, поставляемых в комплекте с программой. Подробную информацию о других 
визуальных объектах дизайнера вы можете найти в документе [2] в разделе «Описание 
визуальных объектов». Визуальные объекты находятся на панели объектов справа. Если эта 
панель не видна, установите галочку в Tools => Toolbars => Objects. Чтобы поместить 



Создание отчетов 

 

© ЛСРМ SpectraLine Отчеты – руководство пользователя 

I-2 

визуальный объект на форму отчета, щелкните на соответствующей ему иконке на панели 
объектов, а затем на форме отчета в том месте, где хотите поместить объект. Изменить свойства 
объекта можно через Object inspector. Для этого выберите Tools => Toolbars => Object 
inspector, откроется окно инспектора объектов. Кроме того, положение и размер объекта можно 
изменять при помощи мыши. 

2.1.3.1.1 Объект «Memo» 

Представляет собой произвольным образом обрамленный прямоугольник с многострочным  

текстом внутри. На панели объектов ему соответствует иконка . В поле объекта может быть 
размещен многострочный текст с переменными. Двойным щелчком по объекту открывается 
редактор объекта. С его помощью можно менять текстовое поле объекта, вставлять переменные и 
выражения с переменными, а также писать скрипты. Переменные в поле объекта обрамляются 
квадратными скобками. Переменную можно вставить вручную, поместив ее имя в квадратных 

скобочках в поле, а можно через список переменных отчета. Для этого щелкните по иконке  
панели инструментов редактора объектов, в открывшемся окне нажмите кнопку Variable, 
откроется список доступных пользователю переменных (см. раздел 2.1.3.3). Нажмите на кнопку 
Function, чтобы вставить в поле выражение, откроется список доступных пользователю функций. 
Подробно о доступных функциях смотрите в документе [2] в разделе «Встроенные функции».  

 

 

Рисунок 2-1. Редактор объекта «Memo» с открытым списком переменных для вставки 
вручную. 

 
Внизу окна редактора объектов расположено поле, содержащее операторные скобки 

begin..end. Оно предназначено для написания скрипта. Скрипт – блок из одного или нескольких 
операторов, который выполняется каждый раз перед формированием объекта. Скрипты пишутся 
на Pascal-подобном языке, что позволяет создавать внутри них переменные и массивы,  
доступные во всем отчете, использовать свойства и методы объектов отчета, поля БД, различные 
константы, процедуры и функции (см. раздел 2.1.3.2).  

Переменная может отображаться как текст, число, дата, время, булевское значение. Для 
каждого из этих типов (кроме текстового представления) можно выбрать один из нескольких 
способов форматирования. Если выбран текстовый тип (по умолчанию), то форматирование 
производиться не будет. Форматирование можно сделать как вручную в поле объекта, так и через 
редактор форматирования – контекстное меню по правой кнопке => Variable format. 
Форматирование вручную, используя строки форматирования, позволяет выбрать для каждого 
типа произвольный формат.  

Применимы следующие тэги форматирования числовых переменных: 

 „ 0 ‟ – метка, определяющая обязательную позицию в выходной строке; если форматируемое 
число имеет цифру в этой позиции, то эта цифра копируется в выходную строку, в противном 
случае в этой позиции будет „0‟; 
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 „ # „– метка, определяющая необязательную позиция в выходной строке; если форматируемое 
число имеет цифру в этой позиции, то эта цифра копируется в выходную строку, в противном 
случае эта позиция будет пустой; 

 „ . ‟ – символ, определяющий позицию десятичного разделителя в форматируемой величине; 

 „ , ‟ – символ, определяющий позицию тысячного разделителя; 

 „ E ‟ – показатель экспоненциального представления числа; если в тэге встречается любая из 
строк „E+‟, ‟E-‟, ‟e+‟, ‟e-‟, то число форматируется с использованием экспоненциального 
представления; 

 
Примеры применения форматирования: 
Без форматирования 1234   -1234  0.5   0 
0     1234       -1234  1   0 
0.00     1234.00  -1234.00  0.50   0.00 
#.##      1234   -1234  .5  
#,##0.00    1,234.00  -1,234.00  0.50   0.00 
#,##0.00;(#,##0.00) 1,234.00  (1,234.00) 0.50   0.00 
#,##0.00;;Zero   1,234.00  -1,234.00  0.50   Zero 
0.000E+00      1.234E+03 -1.234E+03 5.000E-01 0.000E+00 
#.###E-0     1.234E3  -1.234E3  5E-1   0E0 
Подробнее об этом объекте смотри документ [2] в разделе «Объект «Текст». 

2.1.3.1.2 Объект «Band» 

Бэнд представляет собой секцию, выполняющую определенную функцию. На панели 

инструментов ему соответствует иконка . На бэнд помещаются другие объекты, например 
«Рисунок» или «Текст», на которых будет распространяться функция бэнда.  

Доступны следующие бэнды: 

Наименование Функция 

Report title печатается один раз в начале отчета  

Report summary печатается один раз в конце отчета  

Page header   печатается вверху на каждой странице  

Page footer   печатается внизу на каждой странице  

Master header   печатается в начале списка 1-го уровня 

Master data данные списка 1-го уровня  

Master footer печатается в конце списка 1-го уровня  

Detail header печатается в начале списка 2-го уровня 

Detail data данные списка 2-го уровня 

Detail footer печатается в конце списка 2-го уровня 

Subdetail header печатается в начале списка 3-го уровня 

Subdetail data данные списка 3-го уровня 

Subdetail footer печатается в конце списка 3-го уровня 

Overlay печатается на каждой странице нижним слоем 

Column header печатается в начале каждой колонки 

Column footer печатается в конце каждой колонки 

Group header заголовок группы 

Group footer печатается после группы 

Cross header эта группа бэндов предназначена для создания отчетов с 
переменным количеством столбцов и разбивкой на страницы Cross data 

Cross footer 

В частности дата-бэнды используются для построения таблиц. Обычно чтобы построить 
таблицу, нужно указать источник данных. Содержимое дата-бэнда будет выведено в отчет столько 
раз, сколько записей в источнике. Применительно к нашей программе пользователю этого делать 
не нужно. Все необходимые данные уже заложены в соответствующие переменные (см. раздел 
2.1.3.3). 

Подробнее об этом Объекте смотри документ [2] в разделе «Объект «Секция». 

2.1.3.1.3 Объект «Picture» 

Предназначен для вставки графического файла в формате BMP/WMF/ICO (и JPG, если 
установлен соответствующий модуль) в документ. На панели инструментов ему соответствует 
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иконка . Двойным щелчком вызывается редактор объекта, который позволяет вставить рисунок 
и очистить содержимое объекта.  

 

 

Рисунок 2-2. Редактор объекта «Picture» с выбранным рисунком. 

 
В контекстном меню объекта можно задать следующие опции: 

 "растягиваемый" - рисунок растягивается по границам объекта; 

 "сохранять пропорции" - если включено растягивание, пропорции рисунка сохраняются; 

 "центровка" - рисунок выводится в центре объекта. 
Подробнее об этом объекте смотри документ [2] в разделе «Объект «Рисунок». 
 

2.1.3.2 Встроенный интерпретатор 

Для написания скриптов пользователю доступен встроенный интерпретатор Pascal-
подобного языка.  

 

 

Рисунок 2-3. Редактор объекта «Memo» с примером скрипта. 

В качестве языка используется диалект Pascal, со следующими возможностями: 

 операторы: присваивания; условные операторы, операторы циклов и безусловного перехода: 
if...then...else, while...do, repeat...until, for..to..do, goto; 

 операторные скобки begin...end; 

 переменные без типа, массивы; 

 обращение к свойствам и методам объектов FastReport через точечную нотацию. 
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Язык по сравнению с Object Pascal сильно упрощен. Так, используются следующие 
упрощения: 

 все переменные имеют тип Variant; отсутствует описание переменных; 

 все переменные являются глобальными, нет локальных переменных; 

 отсутствуют такие типы данных, как "класс", "запись", перечисляемый тип и т.п.; 

 нет возможности написания собственных процедур или функций; 

 нет операторов прерывания цикла (break, continue); 
Также для числовых переменных в скриптах применимо форматирование. Правила 

форматирование те же, что и для переменных объекта «Memo» (см. раздел 2.1.3.1.1). 
 

2.1.3.3 Список переменных отчетов 

Чтобы открыть список переменных, доступных в отчете, выберите File => Open => Data 
dictionary. В открывшемся окне на закладке Variables содержится список пользовательских 
переменных, разделенный на категории. 

  

 

Рисунок 2-4. Список пользовательских и системных переменных. 

 
Внизу в строке Expression можно задать значение выделенной переменной, которое она 

будет иметь по умолчанию, или сделать ее вычисляемой, сопоставив ей математической 
выражение. Внимание: выражение не должно содержать тэги форматирования! (см. документ [2]). 
Список пользовательских переменных разделен на следующие категории: 

1. Строка данных градуировки 

StringOfEnergy Переменная содержит список линий, которые пользователь хотел бы 
видеть в таблице с данными по градуировке спектрометра (подробнее 
см.ниже ) 

 
2. Заголовки шапки отчета 

CAP_REPORT Заголовок отчета, должен содержать в конце встроенную переменную 
[DATE], отображающую текущую дату – дату создания отчета 

CAP_SPE Заголовок строки со спектром 

CAP_CONF Заголовок строки с конфигурацией 

CAP_DAT Заголовок строки с датой измерения 

CAP_TL Заголовок строки с живым временем 

CAP_TR Заголовок строки с реальным временем 

CAP_OPER Заголовок строки с оператором 
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CAP_GEOM Заголовок строки с геометрией 

CAP_SMASS Заголовок строки с массой 

CAP_VOLUME Заголовок строки с объемом 

CAP_MAT Заголовок строки с материалом 

 
3. Переменные шапки отчета 

SPE_NAME Имя спектра, для которого формируется отчет 

CONF_NAME Наименование конфигурации 

DET_NAME Наименование детектора 

MEAS_DATE Дата измерения спектра 

MEAS_TIME Время измерения спектра 

TIME_LIVE Живое время 

TIME_REAL Реальное время 

SOCKET Гнездо 

MASS_PROB Масса пробы, если присутствует в спектре 

LABEL Метка, если таковая присутствует в спектре 

OPERATOR Оператор 

GEOM_NAME Геометрия 

SP_MASS Масса 

SP_VOLUME Объем 

SP_MATERIAL Материал 

 
4. Таблица данных градуировки 

NUM Номер записи по порядку 

NUCLID_GR Имя нуклида, соответствующего пику 

ENERGY Энергия пика в кэВ 

CHANNEL Положение пика, канал 

PSHPV_GR Полуширина канала в кэВ 

CALIBR_NAME Имя файла, содержащего калибровки для данного спектра 

INL Значение интегральной нелинейности калибровки по энергии 

ENCALIBRATION Формула калибровки.  E = A0 + A1*N + A2*N
2
 +…+Am*N

m
 

 
5. Заголовки таблицы результатов обработки 

CAP_NUC Заголовок столбца с нуклидами и линиями 

CAP_AREA Заголовок столбца с площадью 

CAP_DAREA Заголовок столбца с погрешностью площади 

CAP_ACTIV Заголовок столбца с активностью 

CAP_DACTIV Заголовок столбца с погрешностью активности 

CAP-MASS Заголовок столбца с массовой долей 

 
6. Таблица результатов обработки 

NUCLID Имя нуклида или энергия соответствующей ему линии 

PSHPV Полуширина канала в кэВ 

AREA Площадь пика в импульсах 

DAREA Абсолютная погрешность площади в импульсах 

ACTIVITY Активность в кэВ 

DACTIVITY Относительная погрешность активности в % 

MASS Массовая доля 

 
7. Переменные типа измерения 

CAP_TYPE Заголовок группы, содержащей результаты анализа, соответствующие 
данному типу измерения 

CAP_FIELD1 Заголовок, информирующий о содержании переменной FIELD1 

CAP_FIELD2 Заголовок, информирующий о содержании переменной FIELD2 

CAP_FIELD3 Заголовок, информирующий о содержании переменной FIELD3 

FIELD1 Переменные, содержащие результаты анализа спектра в соответствии с 
заданным типом измерения FIELD2 

FIELD3 
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Переменные данной категории используются совместно, так как только вместе дают полную 
информацию о результатах анализа, соответствующего заданному типу измерения. Каждое из 
полей FIELD1, FIELD2, FIELD3 используется только с соответствующим ему заголовком.  

 
При работе с переменными шаблона следует учитывать следующие особенности: 

 Все переменные, начинающиеся с CAP_, не являются информативными, то есть не зависят 
от спектра и не несут какой-либо информации, относящейся непосредственно к данному 
спектру, а изменяются только в зависимости от выбранного языка (если программа 
поддерживает многоязычный интерфейс). Исключением являются CAP_переменные 
категории «Переменные типа измерения», которые зависят от типа измерения данного 
спектра. CAP_переменные могут быть использованы для составления шаблона отчета, 
изменяющего свои язык в зависимости от языка интерфейса программы. 

 Переменные категорий «Таблица данных градуировки» и «Таблица результатов обработки» 
несут информацию, относящуюся к двум независимым таблицам, поэтому должны быть 
использованы раздельно, то есть на разных бэндах. Их смешение приведет к выводу 
некорректной информации. 

 Переменные категорий «Таблица данных градуировки» и «Таблица результатов обработки» 
несут табличные данные, поэтому должны использоваться совместно с объектами Master 
Data (см. раздел 2.1.3.1.2), позволяющими строить таблицы. 

 Переменная StringOfEnergy категории «Строка данных градуировки» содержит список линий, 
которые пользователь хотел бы видеть в таблице с данными по градуировке спектрометра; 
список состоит из пар «энергия линии - нуклид», заключенных в круглые скобочки, что 
обязательно; разделитель между парами не имеет значения; внутри круглых скобочек энергия 
линии отделяется от нуклида знаком пробела; 
 
Помимо списка пользовательских переменных имеется список встроенных переменных, 

который также может быть использован в отчете. На закладке Variables выберите из 
выпадающего списка справа категорию System variables. Вам доступны следующие значения 
встроенных переменных: 

 Page# - номер текущей страницы; 

 Date - дата начала формирования отчета; 

 Time - время начала формирования отчета; 

 Line# - номер строки; 

 Line through# - номер строки сквозной; 

 Column – номер колонки; 

 Total Pages - всего страниц в сформированном документе. Для использования этого 
значения отчет должен быть двухпроходным (см. руководство [2] [3] [3] ). 

 

2.1.3.4 Вставка графика спектра в отчет 

Чтобы отчет содержал график спектра, поместите на форму в нужное место визуальный 
компонент «Рисунок». Проследите, чтобы его имя было «PictureSpectrum». Если в вашем отчете 
есть объект «PictureSpectrum», не предназначенный для вывода графика спектра, то измените его 
имя на любое другое. Изменить имя объекта можно, вызвав Object inspector(Инспектор 
объектов). Окно инспектора похоже на Object Inspector в Delphi и позволяет изменять такие 
свойства объекта как имя, размер, положение и другие. Щелкните на объекте, свойства которого 
вы хотите изменить, выберите Tools => Toolbars => Object inspector, в поле Name введите 
PictureSpectrum. 

2.1.4 Пример создания шаблона отчета 

Рассмотрим создание шаблона на примере. 
Создайте новый шаблон отчета так, как это описано в разделе 2.1.1. Если форма шаблона 

не пустая, то очистите ее. Поместите на форму бэнд Report title (см. раздел 2.1.3.1.2), измените его 
размер и положение на желаемые. Все объекты, размещенные на этом бэнде, будут выводиться в 
отчете один раз в начале отчета. Разместите на бэнде Memo-объект (см. раздел 2.1.3.1.1) и 
откройте его редактор. Введите текст и/или выберете переменную из списка переменных отчета, 
которые будет выводиться в этом  поле. Например “Имя спектра: [SPE_NAME]”. 
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Рисунок 2-5. Редактор memo-объекта с введенным в поле значением. 

Можете поместить на бэнд еще несколько memo-объектов и заполнить их. Переменные, 
которые предназначены для вывода в начале отчета, находятся в категориях «Заголовки шапки 
отчета» и «Переменные шапки отчета». 

Также на этот бэнд можно поместить объект «Рисунок», в котором можно поместить логотип 
фирмы. 

 

Рисунок 2-6. Бэнд Report title с размещенными на нем объектами. 

Поместите на форму объект Master header. На этом бэнде будет располагаться шапка 
таблицы. Допустим, мы хотим создать таблицу с результатами обработки. Тогда разместите на 
этом бэнде memo-поля, которые будут соответствовать заголовкам столбцов таблицы. Заполнить 
их можно, используя переменные категории «Заголовки таблицы результатов обработки», или 
вручную.  

 

 
Рисунок 2-7. Бэнд Master header 
 
Поместите на форму бэнд Master data, на котором будут располагаться данные таблицы. 

Поместите на него memo-поля, заполните их в соответствии с заголовками таблицы, используя 
переменные категории «Таблица результатов обработки». 

 

 

Рисунок 2-8. Бэнд Master data. 

Аналогичным образом может быть создана таблица с данными градуировки спектрометра, 
используя бэнды Master header и Master data с переменными категории «Таблица данных 
градуировки». Переменные, соответствующие заголовкам столбцов таблицы градуировки, не 
предусмотрены. 

Поместите на форму бэнд Report summary, объекты которого будут печататься в один раз в 
конце отчета. На нем может быть помещена заключительная информация отчета, например, имя 
оператора, а также результаты обработки, связанные с типом измерения. 

Если вы хотите разместить результаты обработки, связанные с типом измерения, то 
поместите на бэнд несколько memo-полей, разместите в них переменные категории «Переменные 
типа измерения», соблюдая соответствие переменных их заголовкам (см. раздел I-5) и порядок 
следования согласно нумерации. 
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Рисунок 2-9. Бэнд Report summary со списком переменных типа измерения. 

 
Также на форме могут быть размещены бэнды Page header и Page footer, объекты которых 

будут выводиться  на каждой странице вверху или внизу соответственно, например, номер 
страницы или название программы.  

 

 
Рисунок 2-10. Бэнд Page footer, несущий номер страницы 
 

2.1.5 Редактирование сформированного отчета 

 Чтобы отредактировать сформированный отчет, кликните дважды левой кнопкой мыши на 
нем. После этого откроется окно дизайнера отчетов, где вместо переменных будут 
соответствующие значения. Редактирование производится средствами дизайнера отчетов. После 
редактирования сохраните изменения и закройте редактор,  вы вернетесь к просмотру 
сформированного отчета. Сохранение изменений в сформированном отчете не повлияет на сам 
шаблон отчета. 

2.2 Работа с окном Отчет 

В программе предусмотрен вариант создания отчетов, содержащих информацию о спектре, 
используя окно Отчет.  

 
Для предварительного просмотра, экспорта, загрузки и печати отчета выберите пункт меню 

Файл => Отчет => Печать… В появившемся окне Отчет задайте параметры отчета: 
1. Выберите данные, которые будут включены в отчет, в группе Включить в отчет: 

 Данные и спектр, 

 Только данные, 

 Только спектр.  
2. Установите или снимите флажки в списке Данные отчета для выбора следующих полей отчета 
(при этом в таблице будут отображены соответствующие данные из спектра): 

 Положение пика Канал. 

 Погрешность Погрешность канала. 

 Энергия пика Энергия. 

 Погрешность энергии Погрешность энергии. 

 Полуширина ПШПВ. 

 Погрешность полуширины Погрешность ПШПВ. 

 Площадь пика Площадь. 

 Погрешность площади Погрешность площади. 
С помощью кнопки Выбрать все можно установить флажки во всех позициях списка. 
3. Установите режим изображения спектра Изображение спектра: 

 Черно-белое изображение Черно-белое. 

 Цветное изображение Цветное. В случае выбора этого режима важно помнить, что фон 
спектра печататься не будет, он останется прозрачным. В соответствующие цвета окрасятся 
только сетка, пики, зоны и курсор. 

 На отдельном альбомном листе На отдельной странице. 

 На одной странице с текстовыми данными На текущей странице. 
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Для экспорта отчета в файл выполните следующие действия:  
1. Выберите формат экспорта отчета в списке Экспортировать в, поддерживаемый средством по 
работе с отчетами FastReport:  

 Экспортировать только текст, без изображений, Только текст (без изображения). 

 Экспортировать в .html- или .htm- файл Интернет эксплорер HTML файл. 

 Экспортировать графический файл Рисунок. 
2. Установите или снимите флаг открытия отчета после экспорта Открыть после экспорта. 
3. Нажмите кнопку Экспорт, в появившемся стандартном окне сохранения файла установите его 
название и место на диске, а затем – параметры экспорта для заданного формата. 

 
Для загрузки отчета из заранее созданного шаблона установите флаг Использовать файл 

отчета, нажмите кнопку Загрузить и в появившемся стандартном окне открытия файла выберите 
.frf – файл. При таком режиме данные из таблицы и списка Данные отчета будут игнорироваться. 
Внимание: шаблоны, описанные в разделе 2.1 настоящего документа, использовать нельзя! 
Данные  шаблоны содержат отличные переменные и источники данных. О создании шаблонов 
отчетов для окна Отчет смотри ниже. 
  

Для предварительного просмотра отчета нажмите кнопку Просмотр. В появившемся 
стандартном окне предварительного просмотра можно выполнить операции масштабирования, 
открытия, сохранения отчета, а также поиска заданного текста. 

 
Для вывода отчета на печать нажмите кнопку Печать и в появившемся стандартном окне 

печати документа задайте настройки печати. 
 
Для завершения работы с отчетами нажмите кнопку Отмена. 
 

  

 Рисунок 2-11. Работа с окном Отчет. 

Для создания шаблона отчѐта для окна Отчет выберите пункт меню Файл => Отчет => 
Дизайн…. Откроется окно дизайнера отчѐтов с загруженным шаблоном по умолчанию, который 
может быть отредактирован. Подробную информацию о разработке отчетов смотрите в 
руководстве [2] и настоящем документе. Отчет, соответствующий данному шаблону можно 
просмотреть 
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Данным отчетам доступен следующий список переменных: 
 

Название Описание 

ДАТА Дата создания отчѐта 

ВРЕМЯ Время создания отчѐта 

ИМЯ_СПЕ Имя спектра, для которого формируется отчѐт 

ИМЯ_КОНФ Имя файла конфигурации 

ДАТА_ИЗМ Дата измерения спектра 

ВРЕМЯ_ИЗМ Время измерения спектра 

ВРЕМЯ_Ж Живое время 

ВРЕМЯ_Р Реальное время 

КАН_ЗАГ Заголовок столбца с каналами 

КАНАЛ Положение пика, канал 

КАНПОГР_ЗАГ Заголовок столбца с погрешностями каналов  

КАНПОГР Погрешность положения пика 

ЭН_ЗАГ Заголовок столбца с энергиями 

ЭНЕРГИЯ Энергия 

ЭНПОГР_ЗАГ Заголовок столбца с погрешностями энергий  

ЭНПОГР Погрешность энергии 

ПОУШ_ЗАГ Заголовок столбца с полуширинами 

ПОЛУШИРИНА Полуширина канала 

ПОЛПОГР_ЗАГ Заголовок столбца с погрешностями полуширин  

ПОЛПОГР Погрешность полуширины канала 

ПЛОЩ_ЗАГ Заголовок столбца с площадями 

ПЛОЩАДЬ Площадь пика 

ПЛПОГР_ЗАГ Заголовок столбца с погрешностями площадей  

ПЛПОГР Погрешность площади пика 

ПИКОВ Число пиков в текущем спектре 

КАН_НАЧ Начальный канал 

КАН_КОН Конечный канал 

 

2.3 Работа с отчетами в окне База спектров 

В окне База спектров имеется возможность формирования следующих отчетов: 

 Отчет с результатами обработки отдельного спектра (см. раздел 2.3.1), 

 Отчет с результатами усреднения по группе спектров (см. раздел 2.3.2), 

 Отчет с результатами обработки параллельных определений (см. раздел 2.3.3). 

2.3.1 Отчет с результатами обработки спектра 

Чтобы сформировать отчет с результатами обработки отдельного спектра, существует два 
способа: 

 Выберите спектр в центральной таблице спектров окна База спектров и нажмите кнопку 
Отчет нижний панели. При этом выведется отчет с результатами обработки спектра, 
записанный в базу вместе со спектром. Если отчет не был записан в базу для выбранного 
спектра, то кнопка Отчет будет неактивна (см. руководство [3] ). 

 Сформировать отчет с результатами обработки отдельного спектра можно, используя данные 
из базы. Для этого в центральной таблице двойным кликом по спектру вызовите дизайнер 
отчетов. В окне дизайнера выберите File=>Open…, выберите файл DBData.frf, выберите 
File=>Preview. В шаблоне использованы переменные множества DataModule1. WiborQuery и 
DataModule1.TableShapka для отображения основных параметров спектра, а также 
переменные множества DataModule1.AktQuery для отображения результатов обработки в 
табличном виде (см. раздел 2.3.4). Подробно о принципах работы с дизайнером отчетов 
смотрите в разделе 2.1.3 (за исключением списка переменных). Также можно использовать 
информацию раздела 2.1.4 с учетом того, что данные шаблоны содержат свой список 
переменных. 

2.3.2 Отчет с результатами усреднения 

Чтобы сформировать отчет с результатами усреднения, нажмите кнопку Отчет на закладке 
Усреднение, которая станет активной после проведения операции усреднения (см. руководство 
[3] раздел 3.4.1). Для формирование данного отчета используется Aver.frf – файл шаблона отчета, 
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находящийся в рабочем каталоге основной программы. В шаблоне использованы переменные 
категории All, а также категории Данные усреднения для формирования таблицы с результатами 
(см. раздел 2.3.4). Подробно о принципах работы с дизайнером отчетов смотрите в разделе 2.1.3 
(за исключением списка переменных). Также можно использовать информацию раздела 2.1.4 с 
учетом того,  что данные шаблоны содержат свой список переменных. 

2.3.3 Отчет с результатами обработки параллельных определений 

Чтобы сформировать отчет с результатами обработки параллельных определений, на 
закладке Альфа выберите нужный шифр и нажмите кнопку Отчет ВОК. Закладка Альфа доступна 
пользователю, только если тип спектра относится к основным (см. руководство [3] раздел 3.4.3). 
Кнопка Отчет активна, если для выбранного шифра была произведена обработка. Для 
формирования данного отчета используется DBAlpha.frf – файл шаблона отчета, находящийся в 
рабочем каталоге основной программы. В шаблоне использованы переменные множества 
DataModule1.AlphaQuery для отображения результатов обработки параллельных определений, а 
также переменные множества DataModule1.WiborQuery для формирования таблицы со 
спектрами, участвовавшими в обработке (см. раздел 2.3.4). Подробно о принципах работы с 
дизайнером отчетов смотрите в разделе 2.1.3 (за исключением списка переменных). Также можно 
использовать информацию раздела 2.1.4 с учетом того, что данные шаблоны содержат свой 
список переменных. 

2.3.4 Список переменных, доступных для формирования отчетов 

Далее приведен список переменных, доступный пользователю для формирования отчета. 
Список далеко не полный, но достаточный для формирования отчета, содержащего любую 
интересующую пользователя информацию. Доступны следующие переменные: 

 

Название множества Описание множества Название 
переменных 

Описание переменных 

DataModule1.AktQuery Информация о 
результатах 
обработки спектра 
или группы спектров 
(может быть 
использован для 
построения таблиц) 

SpectrID Номер спектра в БД 

Nuclid Название нуклида 

SActiwn Активность [Бк] 

SErrAkt Абсолютная погрешность 
активности [Бк] 

Akt Активность, полученная в 
программе [Бк] 

Err Относительная погрешность 
активности [%] 

DataModule1.AlphaQuery Информация о 
результатах 
обработки 
параллельных 
определений 

CAver Среднее значение по 
результатам обработки 

Shifr Шифр параллельных 
определений одного образца 

Data Данные масс-спектрометрии 

CMin Минимальное значение по 
результатам обработки 

CMax Максимальное значение по 
результатам обработки 

Schod Показатель сходимости 

Pogr Абсолютная погрешность 
определяемой величины при 
обработке параллельных 
определений 

Resultat Результат обработки в 
текстовой форме 

Comment Вывод по результатам 
обработки 

File Файлы спектров, 
участвовавших в обработке 

Tip Тип спектра 

Dk Норматив оперативного 
контроля сходимости 

DataModule1.QNuclid Дополнительная Nuclide_Num Номер нуклида 
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информация о 
нуклидах, 
участвовавших в 
обработке спектра 

Nuclide Название нуклида 

Z Заряд ядра 

Weight Относительная атомная масса 

Life Значение периода 
полураспада 

Period Единицы периода полураспада 

Daugch1, 
Daugch2 

Дочерние нуклиды при 
распаде 

Branch1, 
Branch2 

Вероятности появления 
дочерних нуклидов при 
распаде 

DataModule1.SpectrQuery Дополнительная 
информация по 
выбранному спектру 

DataTime Дата и время измерения 

SpectrId Номер спектра 

SpectrName Название спектра 

Data Дата измерения 

Time Время измерения 

LT Живое время  

RT Реальное время 

Zagruzka Загрузка 

DataModule1.TableShapka Информация из 
файла спектра (для 
протокола) 

ID_Spectr Номер спектра 

Dat Дата измерения 

Tim Время измерения 

Material Материал образца 

Path Путь к файлу спектра 

Geometry Геометрия спектра 

TLive Живое время  

TReal Реальное время 

Volume Объем образца 

Massa Масса образца 

Comment Дополнительная текстовая 
информация 

PRData Дата пробоотбора 

Detector Название детектора 

Shifr Шифр пробы 

DataModule1.WiborQuery Данные по группе 
выбранных спектров 
(используется для 
построения таблиц) 

DatTime Дата и время измерения 

GT Живое время 

RT Реальное время 

Spectr_ID Номер спектра 

Spectr_Name Название спектра 

Data Дата измерения 

Time Время измерения 

Zagruzka Загрузка 

Geometry Геометрия спектра 

PrDetector Детектор 

Shifr Шифр пробы 

Operator Оператор 

Переменные категории 
All 

Информация о 
спектрах, 
участвовавших в 
усреднении 

ContSpe Количество спектров, 
участвовавших в усреднении  

AverName Имена спектров, 
участвовавших в усреднении 

PerData Дата пересчета, если таковой 
был произведен 

Переменные категории 
Данные усреднения 

Информация о 
результатах 
усреднения 

Name Название нуклида 

Akt Активность [Бк] 

AbsPogr Абсолютная погрешность [Бк] 

OtnPogr Относительная погрешность 
[%] 

Vklad Вклад [%] 

Переменные категории 
ЭХЗ 

Информация о 
результатах 

Gnezdo Гнездо 

ExitM Выход метки [%] 
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обработки 
параллельных 
определений 
(доступно только в 
DBAlpha.frf) 

Metka Метка [Бк] 

Ug Масса U в пробе 

U234_U238 Отношение активностей U234 
к U238 

SumPu Суммарное содержание 
изотопов плутония 
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[1] SpectraLine_Руководство пользователя 
[2] Fruser 
[3] SpectraLine_DB 
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